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Microsoft Excel 365 
Basic Authoring and Testing Guide 

Document Formatting 

1. Are the filename, workbook, and worksheet titles descriptive, and 
is the file in *.xlsx format, and is the workbook NOT protected? 

How to test 1A, 1B, 1C, 1D 

Instruction 1A and 1B: Find the filename in File Explorer OR the Title bar in MS Excel. For 
example, FundingBudget.xlsx is a descriptive filename, while Worksheet1.xlsx is not. The file must 
be in the *.xlsx format for accessibility testing to be possible. 

Figure 1: Descriptive file name FundingBudget.xlsx displayed in the Title bar 

 

Test 1A: Is the file name descriptive and does it identify the workbook or its purpose? If not, the 
workbook fails this test.  

Test 1B: Is the file in Excel Workbook (*.xlsx) format? If not, the workbook fails this test. 

Instruction 1C: Activate File tab>Save As>More Options to open the Save As options window 
and verify that the Title field displays the document’s title. 

Figure 2: Save As options window displaying a descriptive filename, *.xslx file type, and the 
document title in the Title field. 

 
Test 1C: Does the Title property field display a document title? If not, the document fails this test. 

Instruction 1D: Worksheet protections limit the ability to test for accessibility and can make 
portions or the entire document inaccessible. Activate the Review tab>Protect group option and 
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verify that Allow Edit Ranges button is selectable. If the Allow Edit Ranges button is selectable, 
then restricted editing is turned off.  

Figure 3: Protect group in the Ribbon showing enabled Allow Edit Ranges option 

 

Test 1D: Is the Allow Edit Range option enabled? If not, the worksheet fails this test.   

How to author for accessibility 

A descriptive filename identifying the workbook, or its purpose helps everyone locate, open, and 
switch between documents. The workbook must be in a *.xlsx format because these authoring and 
testing instructions will only work if the file is in the *.xlsx file format. 

• Activate File tab>Save As. 
Note: The Save As option is only available if AutoSave is set to Off. 

• Verify Save As type is set to Excel Workbook (*.xlsx). 
• Save the workbook with a descriptive file name. 

Text Formatting 

2. Are built-in features used to organize content? 
How to test 2A, 2B 

Test 2A: Does each worksheet follow a logical reading order, left to right, then top to bottom? If 
not, it fails this test. 

Test 2B: Can the worksheet be navigated using the up, down, right, or left arrow keys, and does it 
match the logical reading order? If not, it fails this test. 

How to author for accessibility 

To create a worksheet with content in a logical reading order: 

• Start all worksheets in cell A1. 
• Do not span content over multiple rows or columns. 
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Figure 4: Example of Excel Worksheet with logical reading order 

 

3. Are link names descriptive? 
How to test 3 

Instruction 3: Find hyperlinks within a worksheet. 

Test 3: Do links have meaningful names that describe their destination, function, and/or purpose 
OR that are determinable from context? If not, the document fails this test. 

Uniquely Named Link: 
www.section508.gov 

Link Determinable from context: 
Get My Section 508 Questions Answered 

unclear links with no context: 
click here 
https://site.44d76eb66f3943c395cd2d88207a7b57&aqs.docx 

How to author for accessibility 

Assistive technology users rely on meaningful link names to determine the link destination, function, 
or purpose. For example, ambiguous click here links may hinder assistive technology users’ access 
since the link names are all the same, while the destinations may be different. 

Naming/creating links: 

• Select the cell for the hyperlink, type the hyperlink (URL) text and press Enter 
• Verify the hyperlink goes to the intended destination 

To open the Insert Hyperlink configuration window: 

• Press Ctrl+K, or right-click (Shift+F10) to open the context menus and select 
Link>Insert Link 

• In the Insert Hyperlink options window specify/verify the accuracy for the Text to 
display, the Address for the link and its destination, then select OK 

Note: Link destinations can be web pages, existing files (access restrictions apply), emails, and 
specified locations in a document. 

https://section508.gov/content/help-and-faq
https://www.opm.gov/
www.section508.gov
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Figure 5: Insert Hyperlink configuration window 

 

Object Formatting 

4. Is vital information in headers, footers, duplicated in the 
worksheet? 

How to test 4 

Instruction 4: Search for vital information in headers and footers (View>Page Layout>Header) 
(e.g., Respond by X date, CONFIDENTIAL, Do Not Distribute, DRAFT, Controlled Information, etc.).  

Figure 6: Example of vital information repeated in cell A1 of the worksheet 

 

Test 4: Is the vital information in the header duplicated in the first cell (A1) of the worksheet? If 
not, the worksheet fails this test. 
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How to author for accessibility 

Assistive technology does not automatically access information in headers, footers, and watermarks, 
so it is necessary to duplicate any vital information in cell A1, or near the start of the related 
information.  

5. Are data tables created using built-in table format styles? 
How to test 5A, 5B  

Instruction 5A: Find formatted tables in a workbook. Go to Home>Editing group>Find & 
Select>Go To or Ctrl+G to open the Go To options window. Select the table name in the Go To 
options window and activate OK to go to the table.  

Figure 7: Long path to the Go To options window listing formatted table names  

 

Test 5A: Does the Table Design tab>Properties show a uniquely identifiable contextual Table 
Name? If not, the worksheet fails this test. 

Figure 8: Table Design tab> Properties showing a Table Name 

 

Instruction 5B: Place the cursor in a table cell and verify Header Row and/or First Column 
under Table Design menu>Table Style Options group are checked. 
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Figure 9: Formatted data table with Table Style Options for Header Row and First Column 
selected  

 

Test 5B: Are Header Row and/or First Column in the Table Style Options group checked? If 
not, the worksheet fails this test. 

How to author for accessibility 

Assistive technology users need the ability to identify column and row headers in data tables to 
understand the association between table cells and their respective headers. Complex data tables 
cannot be made accessible in MS Excel. Workbooks with complex data tables (data tables with 
multiple header columns and rows and/or that contain merged/split cells) must be converted to an 
accessible format (i.e., a PDF document remediated for accessibility).  

To create a non-complex accessible data table: 

• Activate Insert tab>Table>Create Table 
• Select the columns and rows for the table or enter the data range in the Where is the data 

for your table? field in the Create Table window 
• Activate the My table has headers checkbox and select OK 
• Enter the data in the cells 

All tables must have a unique, contextually identifiable table name. With the table selected, choose 
Table Design tab>Properties group>Table Name field. Enter a unique table name (no spaces) 
in the field to identify the selected table. 

Figure 10: Insert>Table>Create Table options window 
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6. Do images and other objects have alternative text? 
How to test 6 

NOTE: This test is not necessary if the worksheet contains only decorative or no 
images/objects/shapes/graphs, etc.  

Instruction 6: Examine cells surrounding meaningful images/objects/shapes/graphs for a caption 
or text that describes the object. To locate an images/objects/shapes/graph, activate the 
Home>Editing>Find & Select>Go To Special>Objects and activate OK. 

Figure 11: Bar graph with a descriptive caption in the preceding cell.  

 

Test 6: Do meaningful images/objects/shapes in the worksheet have a caption or descriptive text in 
the surrounding cells? If not, the worksheet fails this test. 

How to author for accessibility 

In Excel, images and other objects cannot be anchored. Assistive technology users can locate the 
objects but cannot access the embedded alternative text descriptions. Images and other objects 
include pictures, images of text, images of tables, graphs, shapes, icons with hyperlinks, etc.  

To add captions or alternative text descriptions in Excel: 

• In the Ribbon activate Home>Editing>Find & Select>Go To Special>Objects to locate 
any images, graphs, objects, etc.  

• Expand the width of the row to fit the image, graph, object etc. 
• Enter a caption or alternative text description in any of the cells immediately adjacent to the 

image, graph, object, etc.  

To use the built-in alternative text description option: 

• Select the image, object, or shape.  
• Right click (Shift+F10) and activate Edit Alt Text.  
• In the textbox enter information that states the purpose/contextual description of the image, 

object, etc., (in as few words as possible while remaining clear) OR activate Mark as 
decorative for decorative objects.  

• Close the Alt Text options window. 
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Color Formatting 

7. Are colors and other visual characteristics that convey information 
also described in text? 

How to test 7 

Using only color or other visual characteristics (size, shape, location, etc.) to convey meaning will 
not provide comparable access to people who are blind, have low vision, or are colorblind.  

Instruction 7: Find where color and/or other visual characteristics, such as top green square, large 
yellow rectangle, bottom center, etc., are used to convey meaning.  

Test 7: Is there text that conveys the meaning of the color or other visual characteristics? If not, 
the document fails this test.  

How to author for accessibility 

The following layout tables describe the progress for three projects using only color to represent the 
current project status. Adding text in addition to the color provides comparable information to 
assistive technology users and people who are colorblind. 

Use text descriptions or alternative text to emphasize the meaning of a color or other visual 
characteristics, such as size, shape, and location. 

Table 1: Example of project status tables using only color, and color with text description 
Project Status 

Project A  

Project B  

Project C  

 
Project Status 

Project A On Time 

Project B At Risk 

Project C Late 

 

8. Is the contrast ratio between text and background sufficient? 
NOTE: This test is not necessary, if the worksheet text is black on white background (or close to it). 
This test requires the Colour Contrast Analyser (an external application). 

How to test 8 

Instruction 8: Execute the Colour Contrast Analyser. Drag the Foreground eyedropper icon 
over a sample of the text or image of text. Drag the Background eyedropper icon over a sample 
of the background color. 

Figure 12: Examples of pass and fail results with the Colour Contrast Analyser 

https://www.paciellogroup.com/resources/contrastanalyser
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Test 8: Does color contrast ratio of Foreground (text) and Background ratio meet the minimum 
contrast ratio (4.5:1)? If not, the document fails this test. 
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How to author for accessibility 

People who are colorblind or have low vision will only have comparable access if there is sufficient 
contrast between the text and the background. The contrast standards are: 

Table 2: Table with contrast ratios for types and sizes of text 

Type or Size of Text Contrast Ratio 

Standard text (12 pt regular) 4.5:1 

Large Text (14 pt bold or 18 pt regular) 3:1 
Text or images of text that are part of an inactive user 

interface component, that are pure decoration, that are not 
visible to anyone, or that are part of a picture that contains 

significant other visual content 
Excluded from requirement 

Create content with text, or images of text that use color or shading, with sufficient color contrast. 
If the contrast ratio fails, then adjust the foreground or background until it passes. 
Table 3: Examples of good and insufficient color contrast ratios 

Good Color Contrast Insufficient Color Contrast 

White text on black 
background 

Dark gray text on black 
background 

Dark green text on yellow 
background 

Orange text on yellow 
background 

Light blue text on blue 
background Red text on blue background 

white text on red background Dark green text on red 
background 
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Miscellaneous 

9. Are there accurate, corresponding descriptions of embedded files? 
How to test 9 

NOTE: This test is not necessary, if the workbook does not contain audio, video, or multimedia 
files. 

Instruction 9: Activate the audio-only, video-only, or multimedia file. 

Test 9: Is there an accurate and complete text transcript for multimedia files, text description for 
audio files, and synchronized caption and/or audio description for video files? If not, the workbook 
fails this test. 

How to author for accessibility 

MS Excel workbooks with embedded audio-only, video-only, or multimedia files that contain 
meaningful information must have additional documentation so that individuals with disabilities have 
comparable access to the embedded information. 

• Audio-only files: Should have an accurate and complete transcript 
• Video-only files: Should have an accurate and complete text description 
• Synchronized media (audio and video) files: Should have accurate and complete 

synchronized captions and audio descriptions 

10. Are forms within the workbook avoided? 
How to test 10 

Instruction 10: Check for interactive form fields. Ignore blank table fields used to create fillable 
spaces; these are not interactive form fields. Search for the Excel built-in form features that are 
interactive and can collect data. Automated, interactive, fillable form fields cannot be made 
accessible in Excel. 

Test 10: Is the workbook free of form fields? If not, the workbook fails this test.  

How to author for accessibility 

Forms created in Excel cannot be made accessible for assistive technology users. 

11. Are flashing objects excluded? 
How to test 11 

Test 11: Is the workbook free of all flashing objects? If not, the workbook fails this test. 

How to author for accessibility 

Create content without using flashing objects. Flashing objects can cause seizures and should never 
be used. 
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