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Microsoft Outlook 365 
Basic Authoring and Testing Guide 

Preconditions 
These tests and authoring guidance only apply to messages set to HTML and Rich Text format. 
Messages formatted as Plain Text do not require testing. 

Messages formatted with HTML or Rich Text format allow application of specific structured 
elements, like headings or active hyperlinks. Using these features appropriately we can create a 
more accessible experience for assistive technology users. 

How to Test A, B 

Instruction A: Create new message (Ctrl+N); select Format Text tab, in the Format group 
select HTML. This is a sticky feature.  

Figure 1: Message Format set to HTML 

 
Test B: Is the email message format set to HTML or Rich Text? If not, the email fails this test.  

Instruction B: Use a descriptive subject that clearly identifies the message by its purpose or 
content. An example of a descriptive subject is Screen captures for Word Guidance Training Video. 
An example of a non-descriptive subject is Pictures.  
Test B: Does the email message use a descriptive subject in the Subject line? If not, the email 
fails this test.  

How to author for accessibility: 

A descriptive message subject helps everyone identify the purpose of the email.  
• Start a new message. 
• Use the Subject line to identify the purpose or content of the message. 

Figure 2: Message with a descriptive Subject field 
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1. Do headings in the email use the MS Outlook heading styles? 
How to Test 1 

Note: Most email messages will not contain headings. If a message does not contain headings, this 
test does not apply. 

Instruction 1: Select text that may be a heading and open the Reveal Formatting pane 
(Shift+F1). Check under Paragraph>PARAGRAPH STYLE options for Heading 1, Heading 2, 
Heading 3, etc. 

Test 1: Does the Paragraph Style in the Reveal Formatting pane (Shift+F1) display heading 
levels for the selected text? If not, the message fails this test. 

Figure 3: Reveal Formatting pane showing Paragraph STYLE Heading 1 

 

How to author for accessibility: 

Headings help organize content and make finding information easier. Assistive technology users 
cannot infer meaning from formatted text appearing to be a heading, such as bold, underline, or 
increased font size. Heading styles create structure that assistive technology users can quickly 
access, and aids message navigation based on the heading levels.  

Activate Format Text tab>Styles (Ctrl+Alt+Shift+S to open the Styles pane) and apply the 
appropriate level heading style to all headings in the message. 

Figure 4: Heading styles applied to selected text 
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Either: 
• Activate the heading style and type the heading, OR 
• Type a heading, and with part or all text selected, choose the appropriate level heading 

style. 

If the message contains multiple headings (H1, H2, H3, etc.), then each heading must use a 
different style. To change the appearance of the built in styles, expand the Style menu option, and 
select Modify… to change spacing and appearance (font family, color, size, shading, etc.) 

Figure 5: Modify Style options window 

 

2. Are lists formatted correctly? 
How to Test 2 

NOTE: This test is not necessary if the message does not contain bulleted or numbered list 
elements. 

Instruction 2: Place the cursor on a list item. Open the Reveal Formatting (Shift+F1) pane. 

Figure 6: The Reveal Formatting pane displaying List option under Bullets and Numbering 

 
Test 2: Is the List option visible under Bullets and Numbering in the Reveal Formatting 
pane? If not, the message fails this test. 
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How to author for accessibility: 

Lists help organize and structure content. Assistive technology users cannot infer meaning from lists 
created using only tabs, a dash, or manual numbering. Using built-in list options applies the 
formatting that assistive technology users need to easily identify and navigate lists. 

Activate the Format Text tab>Paragraph group and use the Bullets, Numbering, or 
Multilevel List option when formatting lists in the message. 

To use the built-in list options: 
• Activate the list option and then type a list item, OR 
• Type the list item and then activate the list option. 

Figure 7: Paragraph group displaying options for bulleted, numbered, and multilevel lists 

 

3. Are layout tables formatted correctly?  
How to Test 3A, 3B 

NOTE: This test is not necessary if the message does not contain tables. 

Layout tables allow authors to visually arrange content in email messages that assistive technology 
users can follow and read in a logical order (left to right, then top to bottom). 

Instruction 3A: Select the first cell of the layout table. Use the Tab key to navigate through the 
table. 

Test 3A: Does the tab order follow the logical (left to right, top to bottom) layout? If not, the 
message fails this test. 

Instruction 3B: Right click (Shift+F10) inside a layout table and activate Table 
Properties>Table tab>Text wrapping. 
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Figure 8: Table Properties window with Text wrapping set to None 

 
Test 3B: Is None selected? If not, the message fails this test. 

How to author for accessibility: 

To create a layout table using the table grid option: 
• Activate Insert tab>Table to open the Insert Table options panel. 
• Select the number of cells for columns and rows in the grid to draw the table.  
• Right click (Shift+F10) inside the table and activate Table Properties>Table tab. 
• Verify Text wrapping is set to None. 

Figure 9: Insert Table options with a 4x3 Table grid option activated 

 
To create a layout table using the Insert Table dialog box option 

• Activate Insert tab>Table>Insert Table>Insert Table… (Alt+N, T, I). 
• In the Insert Table dialog box, specify the number of columns (Alt+C), and the 

number of rows (Alt+R). 
• Right click (Shift+F10) inside the table and activate Table Properties>Table tab. 
• Verify Text wrapping is set to None. 
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Figure 10: Insert Table options using the Insert Table…>Insert Table dialog box for a 
table with 4 columns and 3 rows 

 

4. Is text formatted for the intended language 
How to test 4 

Instruction 4: If the email message contains words or phrases in multiple languages, or a 
language other than the defined default language, select that text. Open the Reveal Formatting 
pane (Shift+F1) and verify the listing under Language matches that of the selected text. 

Figure 11: Reveal Formatting pane displaying Russian under Font>Language option for 
the selected text 

 
Test 4: Is the text formatted using the identified language? If not, the message fails this test. 

How to author for accessibility 

A message may contain sections written in different languages. All non-default language text must 
be formatted to reflect its corresponding language so assistive technology can detect the assigned 
language and reproduce the text with the correct pronunciation. 
To set a different language:  

• Select text written in a different language. 
• Activate Review tab>Language group>Language>Set Proofing Language. 
• Select the appropriate language from the list. 
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Figure 12: Language selection for Italian 

 

5. Are link names descriptive? 
How to test 5 

Test 5: Do links have meaningful names that describe their destination, function, and/or purpose 
OR are these determinable from context? If not, the message fails this test. 

Uniquely Named Link:  
www.section508.gov 

Link Determinable from context:  
Get My Section 508 Questions Answered 

Ambiguous links with no context:  
“Get more information here.” 
0https://site.44d76eb66f3943c395cd2d88207a7b57&aqs.docx 

How to author for accessibility 

Assistive technology users rely on meaningful link names to determine the link destination, function, 
or purpose. For example, ambiguous click here links may hinder assistive technology users’ access 
since the link names are all the same, while the destinations may be different. 

Naming/creating links: 
• Type the hyperlink (URL) text and press the Space bar or Enter 
• Verify the hyperlink goes to the intended destination 

To open the Insert Hyperlink configuration window: 
• Press Ctrl+K, or right-click (Shift+F10) to open the context menus and select 

Link>Insert Link 
• In the Insert Hyperlink options window specify/verify the accuracy for the Text to 

display, the Address for the link and its destination, then select OK 

Notes: 
• Link destinations can be web pages, existing files (access restrictions apply), email 

addresses, and specified locations in a document 
• Deleting or backspacing on the last character in the link name will remove the link 

https://www.section508.gov/manage/section-508-assessment/faq/
https://www.washington.edu/accessibility/checklist/links/
www.section508.gov
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Figure 13: Insert Hyperlink configuration window 

 

Object Formatting 
6. Are data tables created using built-in features? 

How to test 6A, 6B, 6C, 6D 

Instruction 6A: Select a table and verify that the Ribbon displays the Table Design/Layout tabs 
instead of the Picture Format tab. If the Picture Format tab shows in the Ribbon, then it’s a 
non-editable image of a table.  

Figure 14: Picture Format tab instead of Table Design tab displaying in menu for what 
visually appears to be a table  

 
Test 6A: Are all data tables in the message editable (data table is not an image)? If not, the 
message fails this test. 

Instruction 6B: Launch the Check Accessibility Inspector Review tab>Check Accessibility to 
verify tables are free of merged and split cells 

Test 6B: Are tables free of merged or split cells? If not, the message fails this test. 
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Figure 15: Complex table with merged and split cells 

 
Instruction 6C: Place your cursor on any cell of a Header Row. Open the Reveal Formatting 
pane (Shift+F1) and verify Repeat as header row is listed under Table>ROW.  

Figure 16: Table Row properties set to Repeat as header row 

 
Test 6C: Is Repeat as header row identified? If not, the message fails this test. 

Instruction 6D: Place the cursor inside a table, right click (Shift +F10), and select Table 
Properties>Table Tab>Text Wrapping.  

Figure 17: Table Properties window with Text wrapping set to None 

 
Test 6D: Is Text Wrapping set to None? If not, the message fails this test. 



Microsoft Outlook 365 Basic Authoring and Testing Guide Page | 10 

How to author for accessibility 

To understand the association between table cells and their respective headers, assistive technology 
users need to be able to identify column and row headers in data tables. Messages with complex 
data tables (data tables with more than one header row, one or more header column, and/or 
merged or split cells), must be converted to an accessible format (i.e. a PDF message remediated 
for accessibility). Complex data tables cannot be made accessible in MS Outlook. 

To create a non-complex accessible data table:  
• Select Insert tab>Table. 
• Select the number of columns and rows. 
• Do not merge or split cells. 
• Place the cursor on the first row, right click (Shift+F10)>Table Properties>Row 

tab>Repeat as header row button. 

7. Do images and other objects have alternative text? 
How to test 7A, 7B 

Images, Objects, Shapes, Charts, etc. allow authors to provide important, meaningful information in 
a visual format. Assistive technology users cannot infer meaning from selecting the illustration 
alone. To provide assistive technology users comparable access to the purpose or meaning of 
graphic content a contextual description in the form of a caption, nearby text, or Alt Text is 
required.  

Instruction 7A: Select an illustration (picture, shape, icon, SmartArt, graph, etc.) and verify there 
is a contextual description in at least one of these options: 

• Alt Text description. Right click (Shift+F10)>View Alt Text… to activate the 
Alt Text pane 

• Figure caption (image can be marked as decorative), or 
• Related in nearby text (image can be marked as decorative) 

Figure 18: Example of a contextual description in the Alt Text pane 
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Figure 19: Figure caption showing below a selected image 

 
Figure 20: Image description in surrounding text with link to Figure caption 

 
Test 7A: Does the image/object/shape have descriptive alternative text, a descriptive caption, or is 
it described in the surrounding text? If not, the message fails this test. 

Instruction 7B: Select an image or object that is just for decoration, activate the Alt Text pane 
right click (Shift+F10)>View Alt Text…, and verify the description field contains two spaces 
between quotation marks. 

Figure 21: Decorative content – alternative text description using “  “ (quote space space quote) 

 
Test 7B: Does the description field of decorative content contain two spaces between quotes? If 
not, the message fails this test. 
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How to author for accessibility 

Assistive technology users cannot infer meaning from images and other objects such as pictures, 
images of text, images of tables, shapes, icons with hyperlinks, etc. A brief description in the form 
of alternative text (Alt Text), a caption or information in the surrounding text relating the purpose 
or meaning of the image/object provides assistive technology users comparable access to the 
content.  

Alternative Text Option:  
• Select an illustration 
• Right click (Shift+F10)>Edit Alt Text… to open the Alt Text pane 
• Enter a brief, accurate description related to the purpose/context of the selected 

illustration. information that acc the purpose (in as few words as possible while remaining 
clear) for a meaningful image or object 
Notes: 
• To add alt text to SmartArt, select the border instead of the individual shapes or 

pieces. 
• In Microsoft Office 365, alternative text descriptions can be generated automatically. 

Users must verify that the generated description is accurately relating the illustration 
and its context.  

• To disable automatic alt text, go to File>Options>Ease of Access>Automatic Alt 
Text and uncheck the Automatically generate alt text for me option.  

Caption Option: 
• Select the illustration. 
• Right click (Shift+F10)>Insert Caption… to open the Caption options window. 
• Type the information in the Caption: field after the label. 
• Set the options for label, position, numbering, etc. 
• Activate OK. 

Figure 22: Caption options window 
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8. Are images, objects, and text boxes placed in line with the text?  
How to test 8 

Instruction 8: Select the image, object or text box in the message, 
right click (Shift+F10)>Wrap Text>In Line with Text. 

Test 8: Is the text box set to In Line with Text? If not, the message fails test.  

Figure 23: Image Layout Options set to In Line with Text 

 

How to author for accessibility 

Assistive technology users cannot access information in text boxes unless they are anchored 
In Line with Text.  

To place images, objects, and text boxes in line: 

• Select the image, object, or text box. 
• Right click (Shift+F10)>Wrap Text>In Line with Text. 

Color Formatting 
9. Are colors and other visual characteristics that convey information 

also described with text?  
How to test 9 

Using only color or other visual characteristics, such as size, shape, or location, to convey meaning 
will not provide comparable access to people who are blind, have low vision, or are colorblind. 

Instruction 9: Find where color and/or other visual characteristics, such as green, large yellow 
square, top left, etc., are used to convey meaning  

Test 9: Is there text that conveys the meaning of the color or other visual characteristics? If not, 
the message fails this test. 

How to author for accessibility 

The following layout tables describe the progress for three projects using colors to symbolize the 
current project status. Adding text in addition to the color provides comparable information to 
assistive technology users and people who are colorblind. 

Use text descriptions to duplicate the meaning of a color or other visual characteristics, such as size, 
shape, and location. 
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Table 1: Example of project status tables using only color, and color with text description 
Project Status 

Project A  

Project B  

Project C  

 

Project Status 

Project A On Time 

Project B At Risk 

Project C Late 

 

10. Is the contrast ratio between text and background sufficient?  
How to test 10 

Note: This test is not necessary, if the message text is black on white background (or close to it). 
This test requires the Colour Contrast Analyser (an external application). 

Instruction 10: Execute the Colour Contrast Analyser. Drag the Foreground eyedropper icon over 
a sample of the text or image of text. Drag the Background eyedropper icon over a sample of the 
background color. 

Figure 24: Examples of pass and fail results with the Colour Contrast Analyser 

 
Test 10: is the message formatted with the correct color contrast ratio? If not, the message fails 
this test. 

https://www.paciellogroup.com/resources/contrastanalyser
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How to author for accessibility 

People who are colorblind or have low vision will only have comparable access if there is sufficient 
contrast between the text and the background. The contrast standards are: 

Table 2: Contrast ratios for types and sizes of text 

Type or Size of Text Contrast Ratio 

Standard text (12 pt regular) 4.5:1 

Large Text (14 pt bold or 18 pt regular) 3:1 

Incidental text, text overlaid on images, and logotypes Excluded from requirement 

Create content with text, or images of text that use color or shading, with sufficient color contrast. 
If the contrast ratio fails, then adjust the foreground or background until it passes 

Table 3: Examples of good and insufficient color contrast ratios 

Good Color Contrast Insufficient Color Contrast 

White text on black 
background 

Dark gray text on black 
background 

Dark green text on yellow 
background 

Orange text on yellow 
background 

Light blue text on blue 
background Red text on blue background 

white text on red background Dark green text on red 
background 

 

Miscellaneous 
11. Are there corresponding descriptions of embedded files and are 

they accurate? 
How to test 11 

NOTE: This test is not necessary, if the message does not contain embedded audio, video, or 
multimedia files. 

Instruction 11: Activate the audio-only, video-only, or multimedia file. 
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Test 11: Is there an accurate and complete text transcript for multimedia files, text description for 
audio files, and synchronized caption and/or audio description for video files? If not, the message 
fails this test. 

How to author for accessibility 

MS Outlook messages with embedded audio-only, video-only, or multimedia files that contain 
meaningful information must have additional documentation so that individuals with disabilities have 
comparable access to the embedded information. 

• Audio only files should have an accurate and complete transcript 
• Video Only files should have accurate and complete text description 
• Synchronized media (audio and video) files should have accurate and complete 

synchronized captions and audio descriptions 

12. Are flashing objects excluded from the message? 
How to test 12 

Test 12: Is the message free of all flashing objects? If not, the message fails this test. 

How to author for accessibility 

Create content without using flashing objects. Flashing objects can cause seizures and should never 
be used. 
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