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[bookmark: PDF_508_Accessibility_Checklist][bookmark: _bookmark0]Preconditions
Is the PDF a PDF Portfolio or does the PDF have file attachments?
How to test
PDF Portfolios are collections of many different documents combined into one PDF (Figure 1). 
Figure 1 - PDF Portfolio
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Instruction 1: Open each individual document in the portfolio and test with the appropriate test process.
Test A: Were all documents tested with the appropriate test process? If not, the PDF fails this test.
Instruction 2: Open the PDF and select “Attachments” from the “Navigation pane” (Figure 2). Open each attachment separately and test with the appropriate test process.
Figure 2: PDF Attachments Pane.
[image: ]
Test B: Were all attachments tested with the appropriate test process? If not, the PDF fails this test. 
Was the PDF generated from Adobe LiveCycle?
How to test
PDFs that show “Adobe LiveCycle Designer” under “Application:” or “PDF Producer:” cannot be tested for accessibility with Acrobat Pro. 
Open the “Document Properties > Description (File > Properties > Description)” tab (Figure 3).
Test: Do “Application” and “PDF Producer” display “Adobe LiveCycle Designer?” If yes, the document cannot be tested with this test process.
Figure 3: Document properties for Adobe LiveCycle document
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[bookmark: _Toc422212102]Scripts 
Adding programming (Scripts) to a document effectively turns it into a software application. Software applications should be tested using software testing methods. 
Run the Accessibility Full Check (View > Tools > Accessibility >Full Check > Start Checking). Expand the “Page Content” category to view issues.
Test: Does “Scripts – Needs manual check,” display under the “Page Content” category (Figure 4)? If so, you need to test with the Department of Homeland Security (DHS) Trusted Tester Process located at: http://www.dhs.gov/compliance-test-processes.
Figure 4: Accessibility Full Check results for a PDF with scripts
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Is the PDF tagged?
How to test
Documents must be tagged to allow checking for Section 508 accessibility. 
Open the “Document Properties > Description (File > Properties > Description)” tab (Figure 5).
Test: Does “Tagged PDF” display “Yes” under “Advanced,” (Figure 5)? If not, the PDF fails this test. 
Figure 5: Document properties for a PDF with tags
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Is the PDF an image-only PDF or does it contain scanned pages?
How to test
All or part of a PDF may be compiled from scanned pages. Scanned pages are actually pictures of the original. Screen readers cannot infer meaning from just a picture. Optical Character Recognition (OCR) software may be used to recognize the images of text in the PDF.
Instruction 1: “Scanned Page Alert” (Figure 6) displays when you open the PDF.
Figure 6: Scanned Page Alert
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Test A: Does your document display a “Scanned Page Alert (Figure 6)” when opened? If yes, the PDF fails this test.
Instruction 2: Run the “Accessibility Full Check (View > Tools > Accessibility > Full Check > Start Checking).” Expand the “Document” category to view Failed issues (Figure 7).
 Figure 7: Accessibility Full Check results for a scanned document
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Test B: Does “Image-only PDF – Failed” display under “Document?” If yes, the PDF fails this test.
Instruction 3: Run the “Accessibility Full Check (View > Tools > Accessibility > Full Check > Start Checking).” Expand the “Document” category in the “Accessibility Checker” pane to view issues (Figure 8). If “Tagged PDF – Failed” displays the document may contain scanned pages. The PDF fails this test
Figure 8: Accessibility Full Check results for a partially scanned document
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Document Properties
Does the PDF have a descriptive file name?
How to test
A descriptive filename that identifies the document or its purpose helps everyone (including people with disabilities) locate, open, and switch between documents. 
Open Document Properties > Description tab (File > Properties > Description).
Test: Does the “File:” identify the document or its purpose (Figure 9)? If not, the PDF fails this test.
Figure 9: Document properties for a PDF with a descriptive file name
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Note: Acrobat Accessibility Check will automatically fail “Document>Title” if the initial view is set to display “File Name.” To avoid this fail condition, open “Document Properties > Initial View (File > Properties > Initial View)” tab, and set “Window Options > Show: Document Title) (Figure 10).
Figure 10: Display Document Title
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Is Assistive Technology access enabled?
How to test
Security settings can prevent users from changing content and enable features, like saving form data; however, these security settings may block Assistive Technology (AT) access to content.
Test: Open “Document Properties > Security tab. (File > Properties > Security)” (Figure 11). Does “Content Copying for Accessibility” display “Allowed?” If not, the PDF fails this test.
Figure 11: Document properties for a PDF that allows content copying for accessibility
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[bookmark: _Is_the_document]Is the document language set?
How to test
Screen readers access the “Language” setting in “Document Properties” to provide the appropriate pronunciation when reading the document.
Open “Document Properties > Advanced” tab (File > Properties > Advanced)”
Test: Does “Reading Options > Language” display the appropriate document language (Figure 12)? If not, the PDF fails this test.
Note: If the required language is not available from the drop down menu, you can type it in.
Figure 12: Document properties for a PDF with English as the main language
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Structure Tags
Do the tags follow the visual/logical order of the document?
How to test
Screen readers rely on tags to interpret the document structure (headings, paragraphs, lists, images, data tables, forms, and other objects). All meaningful text and objects must correspond to a tag, and the order of the tags must follow the visual/logical order of the document.
Instruction 1: Enable the “Tags” pane. (View > Show/Hide > Navigation Panes > Tags) (Figure 13). Enable “Highlight Content” from the “Tags” pane “Options” menu (Figure 14). 
Test A: Are all meaningful objects and text highlighted? If not, the PDF fails this test.
Figure 13: Enable Navigation Panes/Tags
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Instruction 2: Select the plus symbol on “Tags” (Figure 15) to expand all tags. Press ”Ctrl + A” to select all tags. Use the up and down arrow keys to move through the tags.
Test B: Do the tags follow the visual/logical order on the page (Figure 15)? If not, the PDF fails this test.
Figure 14: Tags Options Menu – Highlight Content enabled
[image: ]
Figure 15: Example of expanded tags that follow the visual/logical order
[image: K:\508 testing and Remediation\Checklists\Screen Captures\LogicalROrder.png]
Does the document have decorative content?
How to test
Decorative content, such as ornamental images and redundant text, should be set to Artifact so screen readers can skip over it.
Open the “Tags” pane (Figure 13) (View > Show/Hide > Navigation Panes > Tags). Select “Find” from the “Tags Options” menu (Figure 16). In the “Find Element” window, select “Artifacts > Search Document > Find > Find Next” (Figure 17) to move through all artifacts in the document.
Figure 16: Tags Options menu - Find selected
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Figure 17: Example of artifacted decorative content
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Test: Does all decorative content (text and objects) show as “Artifact?” If not, the PDF fails the test.
Is vital information in headers, footers, and watermarks duplicated in the document?
How to test
Locate vital information in headers, footers, and watermarks (e.g. Respond by X Date, CONFIDENTIAL, or Do Not Distribute) (Figure 18). Locate the first page or section to which the vital information applies. Highlight the second instance of the vital information on the same page. 
Open the “Tags” pane. (View > Show/Hide > Navigation Panes > Tags). Find the tag corresponding to the vital information. (Tags Pane > Find Tag from Selection).
Figure 18: Example of vital information repeated as tagged content
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Test: Is the vital information repeated as tagged content? If not, the PDF fails this test.
Are the headings in the document tagged with heading tags?
How to test
Headings are used to break-up content and make finding information easier. AT cannot infer meaning from just formatting, like bold or underline, so visual headings must correspond to a heading tag and heading tags (i.e. H1, H2, H3) must match the visual outline.
Instruction 1: Open the “Tags” pane (View > Show/Hide > Navigation Panes > Tags). Select a heading tag (<H1>, <H2>, etc.) (Figure 19).
Test A: Do the heading tags correspond to the document headings and do they follow the visual outline (Figure 19)? If not, the PDF fails the test.
Figure 19: Example of headings that match the visual outline and hierarchy
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Instruction 2: Locate nonstandard PDF tags (e.g. <Title>, <H_1>, <Section>; <Heading3>.) Check the appropriate mapping, by opening the “Role Map.” (Tags > Edit Role Map). Expand “Document Roles” to check mapping.
Test B: Are all non-standard heading tags mapped to the standard heading tags (Figure 20)? If not, the PDF fails the test.
Figure 20: Document Role Maps
[image: ]
Are lists tagged correctly?
How to test
Screen readers cannot infer meaning from just symbols and indents. List tags create a structure that screen readers can identify.
Open the “Tags” pane (Figure 21) (View> Show/Hide > Navigation Panes > Tags). Locate bulleted, numbered, or multilevel lists in the document. Highlight the list content and find its corresponding tag (Tags Pane > Options > Find Tag from Selection). Expand the list tag (select the “+” sign next to the <L> tag).
Test: Does the highlighted content have a parent list tag <L> and have one or more nested list item tags <LI> under the parent <L> tag? If not, the PDF fails the test.
Figure 21: Example of the correct list structure
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Are sections that contain text in different languages tagged with the corresponding language attribute?
How to test
When the language of a paragraph differs from the document language, screen readers access the language in Tag Properties to provide the appropriate pronunciation for the section.
Identify any sections in the document that differ from the document language (exclude proper names, technical terms, or commonly used foreign words). Open the “Tags” pane (View > Show/Hide > Navigation Panes > Tags). Select the section with the different language. Find the corresponding tag (Tags Pane > Find Tag from Selection). Open the “Tag Properties” (Alt + Enter > Tag > Language) (Figure 22).
Test: Does the Language field display the selection’s language or a two-letter code for the representation of the language name? If not, the PDF fails the test.
Figure 22: Example of a PDF with section languages identified in Tag Properties
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Objects
Do all meaningful images and other objects in the PDF have a description of their purpose or function?
How to test
Screen readers cannot infer meaning from images and other objects (pictures, images of text, charts, diagrams, shapes, icons with hyperlinks, etc.). Meaningful images must be accompanied by text that describes the purpose or function.
Note: Images of, or that contain text (i.e. logos, or agency seals) should have the text in the image included in the alternative or descriptive text
Instruction 1: View “Figures” (Tools > Accessibility > TouchUp Reading Order). Check “Show tables and figures” (Figure 23). Right click the content tagged as “Figure” and select “Edit Alternate Text.”
Figure 23: Image with alternative text description and caption
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Test A: Does all content tagged as “Figure” have alternative text that describes its purpose or function? If not, the PDF fails this test.
Instruction 2: Find images/objects that have a caption.
Test B: Do all captions describe the purpose or function of the image/object associated with it? If not, the PDF fails this test.
Instruction 3: Examine the surrounding content for text that describes the purpose or function of untagged (artifact) images.
Test C: Does the descriptive text convey the purpose and/or function of the image or object? If not, the PDF fails this test.
Does the PDF have data tables?
How to test
Data tables in PDFs must be tagged as “Table.” Column and row header cells must be tagged as “Table Headers”. Tables containing multiple header rows, or cells that span multiple rows or columns are complex tables and must have data / header associations to be accessible. 
Instruction 1: Locate programmatically identified data tables. Open the “Order” pane (View > Show/Hide > Navigation Panes > Order) (Figure 24).
Figure 24: Enable Navigation Pane/Order
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Test A: Are the tables identified as “Table” (Figure 24)? If not, the PDF fails this test.
Figure 25: Data table marked as "Table"
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Instruction 2: Find all programmatically identified tables and check if table header cells are tagged as table headers. Open the “Order” pane (View > Show/Hide > Navigation Pane > Order) (Figure 24). Open the “Table Editor” (Right click on the table > Table Editor. Select “Show cell type (TH or TD)” checkbox).
Test B: Are the table header cells marked with TH and are the data cells marked with TD (Figure 26)? If not, the PDF fails this test.
Figure 26: Table header cells are marked with "TH" and table data cells are marked with "TD"
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Instruction 3: If the table is a complex table, right click each table cell and select “Table Cell Properties.” For Header Cells check:
“Header Cell” is checked
Scope indicates “Column” or “Row”
Attributes indicates correct “Row Span” and “Column Span”
ID has a unique identifier (Figure 27)
Test C: Does the Header Cell, scope, row and column span match the visual layout, and does ID display a unique identifier? If not, the PDF fails this test.
Figure 27: Complex table with table cell properties for a header cell showing scope, row and column span and unique ID.
[image: ]
Instruction 4: If the table is a complex table, right click each table cell and select “Table Cell Properties.” For Data Cells check:
1. Data Cell is checked
Associated Header Cell IDs are listed (Figure 27)
Figure 28: Table cell properties for a data cell
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Test D: Are Data Cells associated with Header Cell IDs (Figure 29)? If not, the PDF fails this test.
Figure 29 - Example of data cell association with header cells
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Does the PDF have links and controls?
How to test
Links and controls must:
1. Be uniquely identified
Describe the destination, function, and/or purpose in the name or within context
Be in a tab order that matches the visual/logical order of interactive elements (links, controls, and form fields)
Press the Tab key to find links and user controls. Check that each link has an unambiguous name that describes its destination, function, and/or purpose OR that this is determinable within context (Table 1). For images that are a link or user control, the alt-text may contain the link purpose, function, or destination (Item 15).	Comment by Yeager Rodriguez, Karlo: I can't find the item referenced, here. Has this survived from a different draft?
Table 1: Examples of link names
	Uniquely Named Link:
	…further guidance is available on
www.section508.gov

	Links Determinable within Context:
	Additional guidance is available in the AED COP best practices library. 	Comment by Yeager Rodriguez, Karlo: Link needed, here.

	Ambiguous Links Not Determinable Within Context:
	Click here / Click here for information about each topic.	Comment by Yeager Rodriguez, Karlo: Link needed, here.


Test: Does the link have a unique name that describes the destination, function, and/or purpose OR that is determinable within context as shown in Table 1? If not, the PDF fails this test.
Is the PDF a fillable form?
How to test
It is necessary to provide instruction, directions and cues for completing a form with assistive technology to correctly and accurately enter information in the appropriate fields. 
Instruction 1: All form fields must have a tooltip and the tool tip must match its label or instruction (Figure 30).
Figure 30: Example of a fillable form, with text field with a tooltip
[image: C:\Users\161533\AppData\Local\Temp\SNAGHTML1b59a15.PNG]
Test A: When you hover over each form field, is a tooltip revealed and does the tooltip match the label or instruction? If not, the PDF fails this test.
Instruction 2: Press the tab key to find form fields (text fields, radio buttons, checkboxes, combo boxes, etc.). The tab order must match the visual layout of the form.
Test B: When you tab through the PDF, does the tab order match the visual/logical order of form fields? If not, the PDF fails this test.
Are colors and other visual characteristics (such as size, shape, and location) that convey information also described in text?
How to test
Using only color or other visual characteristics to convey meaning will not provide comparable access to people who are blind, have low vision, or are colorblind.
Find where you have used color and/or other visual characteristics to convey meaning such as green, yellow, red, etc. (Figures 31 and 32).
Figure 31: Inaccessible example	Figure 32: Accessible example
[image: ]	[image: ]
Test: Is there text that conveys the meaning of the color or other visual characteristics? If not, the PDF fails this test.
Is the color contrast ratio between text and background sufficient?
How to test
Note: If the document text is black on white background (or close to it), you do not need to perform this test.
Execute the Colour Contrast Analyser. Select Download (the application can be executed without downloading it onto your computer). Open the Colour Contrast Analyser. Drag the “Foreground” eyedropper icon over a sample of your text or image of text. Drag the “Background” eyedropper icon over a sample of your background color.
Test: Does the color contrast ratio in the PDF pass (AA) for Text (4.5:1) and Large text (3:1) standards? If not, the PDF fails this test (Figures 33 and 34).
Figure 33: Color contrast pass example	Figure 34: Color contrast fail example
[image: ] [image: ]
Miscellaneous
[bookmark: _GoBack]Does the PDF contain audio-only, video-only, or Synchronized media objects that contain meaningful information?
How to test
PDFs that contain audio, video, or multimedia files must have additional information so individuals with disabilities have comparable access to the information (Table 2).
Table 2: Additional information required listed by object type
	Type
	Also include:
	What is this?

	Video-only
	Accurate and complete text description
	A description is a text version of what is being shown in a video-only file.

	Synchronized media (audio and video)
	Accurate, complete, and synchronized captions and audio descriptions
	Captions are time-synchronized text version of exactly what is being said and/or a description of the relevant sounds in the multimedia file. Audio descriptions are time- synchronized descriptions of key information that is being shown visually only in the multimedia file.


Note: If the PDF does not contain audio, video or synchronized media files, you do not need to perform this test. 
Instruction: Activate the meaningful audio-only object
Test A: Does the audio-only object have transcript that is accurate and complete? If not, the PDF fails this test.
Test B: Does the video-only object have text description that is accurate and complete? If not, the PDF fails this test.
Test C: Does the multimedia (audio and video) have synchronized captions and audio description that are accurate and complete? If not, the PDF fails this test.
Does the PDF have flashing objects?
How to test
Federal agencies do not typically see flashing objects embedded into documents. Since flashing objects may be a public safety issue for individuals with photosensitive epilepsy and there is not typically a compelling business need, flashing objects should be excluded. If you feel you do have a compelling business need, please contact the AT Team for assistance in ensuring your object flashes below 3Hz.
Does the PDF need an alternative accessible version?
How to test
Federal agencies have the goal to produce one accessible document for everyone. However, there may be times when this is not feasible. Therefore, it is recommended that you contact the AT Team to ensure an alternative version is necessary, as you are still required to create an alternative version that is accessible, up-to-date and has equivalent content.
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